Помощничек
Главная | Обратная связь


Археология
Архитектура
Астрономия
Аудит
Биология
Ботаника
Бухгалтерский учёт
Войное дело
Генетика
География
Геология
Дизайн
Искусство
История
Кино
Кулинария
Культура
Литература
Математика
Медицина
Металлургия
Мифология
Музыка
Психология
Религия
Спорт
Строительство
Техника
Транспорт
Туризм
Усадьба
Физика
Фотография
Химия
Экология
Электричество
Электроника
Энергетика

Статическая маршрутизация. Конфигурирование статических маршрутов.



 

Статические маршруты обычно используются, когда необходимо прописать маршрут в сеть, достижимую только по одному маршруту.

Статические маршруты также используются для прописывания «маршрута по умолчанию» - default gateway.

Так же статическая маршрутизация может использоваться для прописывания транзитного маршрута через сеть в целях обеспечения безопасности в данной сети.

Статический маршрут настраивается для соединения с удаленными сетями непосредственно не подключенными к маршрутизатору. Для двухстороннего взаимодействия статический маршрут должен быть настроен в обоих направлениях.

 

Настроим маршрутизаторы в соответствии со схемой

 

 

R1(config)#interface fastEthernet0/0

R1(config-if)#ip address 172.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#

1d21h: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

R1(config-if)#^Z

R1#

1d21h: %SYS-5-CONFIG_I: Configured from console by console

R1(config)#interface serial0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#^Z

R1#

1d21h: %SYS-5-CONFIG_I: Configured from console by console

R1(config)#interface serial0/1

R1(config-if)#ip address 192.168.2.1 255.255.255.0

R1(config-if)#clock rate 56000

R1(config-if)#no shutdown

R1(config-if)#^Z

R1#

1d21h: %SYS-5-CONFIG_I: Configured from console by console

1d21h: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up

1d21h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state

to up

R1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration...

[OK]

R1#show startup-config

Using 577 out of 29688 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R1

!

logging rate-limit console 10 except errors

!

ip subnet-zero

!

no ip finger

!

interface FastEthernet0/0

ip address 172.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.1.1 255.255.255.0

!

interface Serial0/1

ip address 192.168.2.1 255.255.255.0

!

ip classless

no ip http server

!

!

line con 0

transport input none

line aux 0

line vty 0 4

!

no scheduler allocate

end

 

R2#configure

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#interface fastEthernet 0/0

R2(config-if)#ip address 10.1.1.1 255.255.255.0

R2(config-if)#no shutdown

00:05:18: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

00:05:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, chang

ed state to up

R2(config-if)#exit

R2(config)#

00:05:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, chang

ed state to down

R2(config)#interface serial0/1

R2(config-if)#ip address 192.168.1.2 255.255.255.0

R2(config-if)#clock rate 56000

R2(config-if)#no shutdown

00:08:52: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up

00:08:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed sta

te to up

R2(config-if)#^Z

R2#

00:09:00: %SYS-5-CONFIG_I: Configured from console by console

00:09:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed sta

te to down

00:09:18: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up

00:09:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed sta

te to up

R2#copy running-config startup-config

R2#show running-config

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R2

!

ip subnet-zero

!

voice-port 1/0/0

!

voice-port 1/0/1

!

interface FastEthernet0/0

ip address 10.1.1.1 255.255.255.0

no ip directed-broadcast

duplex auto

speed auto

!

interface Serial0/0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

!

interface Serial0/1

ip address 192.168.1.2 255.255.255.0

no ip directed-broadcast

!

ip classless

no ip http server

!

 

R3(config)#interface ethernet0

R3(config-if)#ip address 11.1.1.1 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#^Z

R3#

%SYS-5-CONFIG_I: Configured from console by console

%LINK-3-UPDOWN: Interface Ethernet0, changed state to up

R3(config)#interface serial0

R3(config-if)#ip address 192.168.2.2 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#^Z

R3#

%SYS-5-CONFIG_I: Configured from console by console

%LINK-3-UPDOWN: Interface Serial0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

R3#copy running-config startup-config

Building configuration...

[OK]

R3#show startup-config

Using 355 out of 7506 bytes

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname R3

!

interface Ethernet0

ip address 11.1.1.1 255.255.255.0

!

interface Serial0

ip address 192.168.2.2 255.255.255.0

no fair-queue

!

interface Serial1

no ip address

shutdown

!

no ip classless

 

Пока на маршрутизаторах не прописаны маршруты, то они видят только те сети, которые непосредственно к ним подсоединены.

 


C маршрутизатора R1 выполним команду ping 192.168.1.2. Так как эта сеть непосредственно подсоединена к R1, то на ICMP echo request получены отклики ICMP echo replay.

 

R1#ping 192.168.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms

R1#

 

 

 

Теперь с R1 выполним команду ping 10.1.1.1. Так как эта сеть непосредственно не подсоединена к R1, то на ICMP echo request отклики получены не были.

 

R1#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R1#

 

Картинка 3.1

 

 


Для настройки статического маршрута необходимо ввести команду ip route в режиме глобальной конфигурации.

 

Router(config)#ip route network [mask] {address| interface} [distance] [permanent]

 

Параметры, определяющие статический маршрут.

 

Параметры команды ip route Описание
network Сеть, подсеть или хост назначения.
mask Маска подсети.
address IР-адрес следующего интерфейса следующего маршрутизатора (next hop).
interface Если используется соединение типа точка-точка, то можно указывать имя интерфейса для достижения сети назначения. Команда не будет корректно работать при подключении через интерфейс множественного доступа (Ethernet).
distance Определение административной дистанции (необязателен).
permanent Определяет, что маршрут не удалится, даже если отключить интерфейс (необязателен).

 

Значением административной дистанции являются целые числа в диапазоне от 0 до 255. Маршрут с меньшим значением административной дистанции заслуживает большего доверия, чем с большим значением.

 

Настроим статические маршруты из сети 172.1.1.0 в сети 10.1.1.0 и 11.1.1.1 (маска 255.255.255.0). Так как маршрутизаторы соединены между собой по последовательным интерфейсам, то один маршрут пропишем используя ip-адрес, а другой с использованием имени интерфейса.

 

 

R1(config)#ip route 10.1.1.0 255.255.255.0 192.168.1.2

R1(config)#ip route 11.1.1.0 255.255.255.0 serial0/0

R1(config)#^Z

R1#

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets

S 10.1.1.0 [1/0] via 192.168.1.2

11.0.0.0/24 is subnetted, 1 subnets

S 11.1.1.0 is directly connected, Serial0/0

C 192.168.1.0/24 is directly connected, Serial0/0

C 192.168.2.0/24 is directly connected, Serial0/1

R1#

 


 

Теперь с WS1 выполним команду ping на WS4. Ответ получен не был, так как на маршрутизаторе R2 не был прописан маршрут с WS4 к WS1.

 

Пример и рисунок 3.2

 

C:\>ping 192.168.2.2

Обмен пакетами с 192.168.2.2 по 32 байт:

Превышен интервал ожидания для запроса.

Превышен интервал ожидания для запроса.

Превышен интервал ожидания для запроса.

Превышен интервал ожидания для запроса.

Статистика Ping для 10.1.1.2:

Пакетов: отправлено = 4, получено = 0, потеряно = 4 (100% потерь),

Приблизительное время передачи и приема:

наименьшее = 0мс, наибольшее = 0мс, среднее = 0мс

После того, как на маршрутизаторе R2 был прописан маршрут с WS4 к WS1:

ip route 172.1.1.0 255.255.255.0 192.168.1.1

был получен ответ

C:\>ping 10.1.1.2

Обмен пакетами с 10.1.1.2 по 32 байт:

Ответ от 10.1.1.2: число байт=32 время=20мс TTL=126

Ответ от 10.1.1.2: число байт=32 время=20мс TTL=126

Ответ от 10.1.1.2: число байт=32 время=20мс TTL=126

Ответ от 10.1.1.2: число байт=32 время=20мс TTL=126

Статистика Ping для 10.1.1.2:

Пакетов: отправлено = 4, получено = 4, потеряно = 0 (0% потерь),

Приблизительное время передачи и приема:

наименьшее = 20мс, наибольшее = 20мс, среднее = 20мс

C:\>

 

Для проверки целостности маршрутной информации необходимо использовать расширенную команду ping (extended ping), в которой указывается ip-адрес источника и ip-адрес назначения.

 

R2#ping

Protocol [ip]:

Target IP address: 172.1.1.2

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: 10.1.1.1

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/36 ms

R2#

Рисунок 4





©2015 studopedya.ru Все права принадлежат авторам размещенных материалов.