Помощничек
Главная | Обратная связь


Археология
Архитектура
Астрономия
Аудит
Биология
Ботаника
Бухгалтерский учёт
Войное дело
Генетика
География
Геология
Дизайн
Искусство
История
Кино
Кулинария
Культура
Литература
Математика
Медицина
Металлургия
Мифология
Музыка
Психология
Религия
Спорт
Строительство
Техника
Транспорт
Туризм
Усадьба
Физика
Фотография
Химия
Экология
Электричество
Электроника
Энергетика

Настройка динамической трансляции адресов (Dynamic NAT).



 

Для установки динамической трансляции между внутренними локальными адресами и внутренними глобальными адресами необходимо в режиме глобальной конфигурации определить пул глобальных адресов.

 

Router (config) # nat рооl name start-ip end-ip (netmasknetmask | prefix-length prefix-length)

 

Устанавливается стандартный список контроля доступа (АСL) (номер от 0 до 99), который будет разрешать транслировать внутренние локальные адреса. Для группы последовательных адресов можно применить wildcard mask. Если адреса являются непоследовательными, то каждый адрес описывается отдельной строчкой в ACL.

 

Router (config) # ассеss-list ассеss-list-number permitsource [source wildcard]

Затем необходимо установить динамическую трансляцию адресов источника. Устанавливается связь между пулом внутренних глобальных адресов и адресами, указанными в списке доступа.

 

Router (config) # iр nat inside source list access-list-numberpoolname

Определяем, какой интерфейс маршрутизатора будет являться внешним локальным. Входим в подрежим конфигурирования этого интерфейса и вводим команду ip nat inside.

 

Router(config)# interfacetype number

Router(config-if)# ip nat inside

 

Определяем, какой интерфейс маршрутизатора будет являться внешним. Входим в подрежим конфигурирования этого интерфейса и вводим команду ip nat outside.

 

Router(config)# interfacetype number

Router(config-if)# ip nat outside

 

 

Для удаления пула глобальных адресов необходимо в режиме глобальной конфигурации надо ввести команду no ip nat pool.

Для удаления ACL необходимо в режиме глобальной конфигурации надо ввести команду no ассеss-list ассеss-list- number.

Для отключения динамической трансляции адресов источника в режиме глобальной конфигурации надо ввести команду no iр nat inside source.

 

ЗамечаниеАСL должен разрешать только те адреса, которые должны быть транслированы. Необходимо помнить о правиле работы ACL- что не разрешено – то запрещено. Не рекомендуется так же использовать команду “permit any” .

 


Настроим динамическую трансляцию адресов на маршрутизаторе с пулом внутренних глобальных адресов 200.1.1.2, 200.1.1.3, 200.1.1.4.

 

Рис 4.

 

R1(config)#interface fastethernet 0/0

R1(config-if)#ip address 10.1.1.1 255.255.255.0

R1(config-if)#ip nat inside

R1(config-if)#^Z

R1(config)#interface serial 0

R1(config-if)#ip address 200.1.1.1 255.255.255.0

R1(config-if)#ip nat outside

R1(config-if)#^Z

R1(config)#ip nat pool bob 200.1.1.2 200.1.1.4 netmask 255.255.255.0

R1(config)#ip nat inside source list 1 pool bob

R1(config)#access-list 1 permit 10.1.1.2

R1(config)#access-list 1 permit 10.1.1.3

R1(config)#access-list 1 permit 10.1.1.4

R1(config)#^Z

R1#

 

Просмотр результатов настройки можно выполнить с помощью команды show running-config.

 

R1# show running-config

!

interface FastEthernet0/0

ip address 10.1.1.1 255.255.255.0

no ip directed-broadcast

ip nat inside

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 200.1.1.1 255.255.255.0

no ip directed-broadcast

ip nat outside

no ip mroute-cache

no fair-queue

!

!

ip nat pool bob 200.1.1.2 200.1.1.4 netmask 255.255.255.0

ip nat inside source list 1 pool bob

ip classless

no ip http server

!

access-list 1 permit 10.1.1.2

access-list 1 permit 10.1.1.3

access-list 1 permit 10.1.1.4

!


Для просмотра информации о трансляции надо выполнить команду show ip nat translations, которая показывает активные трансляции.

 

R1# show ip nat translations

Pro Inside global Inside local Outside local Outside global

--- 200.1.1.2 10.1.1.2 --- ---

--- 200.1.1.3 10.1.1.3 --- ---

R1#

 

 

Для просмотра статистики по трансляциям надо выполнить команду show ip nat statistics.

 

R1#show ip nat statistics

Total active translations: 0 (0 static, 0 dynamic; 0 extended)

Outside interfaces:

Serial0/0

Inside interfaces:

FastEthernet0/0

Hits: 0 Misses: 0

Expired translations: 0

Dynamic mappings:

-- Inside Source

access-list 1 pool bob refcount 0

pool bob: netmask 255.255.255.0

start 200.1.1.2 end 200.1.1.4

type generic, total addresses 3, allocated 0 (0%), misses 0

R1#

 




©2015 studopedya.ru Все права принадлежат авторам размещенных материалов.