Помощничек
Главная | Обратная связь


Археология
Архитектура
Астрономия
Аудит
Биология
Ботаника
Бухгалтерский учёт
Войное дело
Генетика
География
Геология
Дизайн
Искусство
История
Кино
Кулинария
Культура
Литература
Математика
Медицина
Металлургия
Мифология
Музыка
Психология
Религия
Спорт
Строительство
Техника
Транспорт
Туризм
Усадьба
Физика
Фотография
Химия
Экология
Электричество
Электроника
Энергетика

Настройка транковых соединений.



На коммутаторах Cisco 2950 следующие параметры установлены по умолчанию:

 

Имя домена VТР: отсутствует

Режим VТР: Сервер

• Пароль VТР:отсутствует

• Сокращение объявлений VТР: выключена

• VТР trap:выключено

 

Коммутатор Саtalyst серии 2950 поддерживает только инкапсуляцию 802.1Q, которая автоматически включается при переводе порта в режим транка.

Опции конфигурирования транковых соединений в подрежиме switchport mode.

 

Опция Описание
access Выводит порт из режима транкового соединения
trunk Переводит порт в режим транкового соединения и взаимодействует с подключенным устройством для определения протокола 802.1Q или ISL
dynamic desirable Переключает порт для определения транкового соединения. Порт становится транковым, если подключенное устройство находится в режимах trunk, dynamic desirable, dynamic auto. В противном случае порт становится нетранковым.
dynamic auto Переводит порт в транковое состояние, если подсоединенное устройство в режиме dynamic desirable или trunk

 


 

Рассмотрим настройку транковых соединений для сети, представленной на рис.31.

 

рис 31.

 

Настроим коммутатор SW1 как VTP сервер. Для этого входим в режим конфигурации VLAN на SW1 и установим VTP домен с именем "VTP_test" с помощью команды "vtp domain vtp_test". Все коммутаторы по умолчанию считают себя VТР серверами, поэтому SW1 автоматически им становится. Создадим VLAN 3 с именем test_3. Выходим из режима конфигурации VLAN для настройки интерфейсов.

 

SW1#vlan database

SW1 (vlan)#vtp domain vtp_test

SW1 (vlan)#vlan 3 name test_3

VLAN 3 added:

Name: test_3

SW1(vlan)#exit

APPLY completed.

Exiting....

 

В режиме глобальной конфигурации входим в подрежим интерфейса fa0/2 и помещаем его в VLAN 3. Затем настраиваем интерфейс fa0/1 как транковый. Для этого в подрежиме конфигурации интерфейса fa0/1 вводим команды "switchport mode dynamic desirable" и "switchport mode trunk". Эти команды необходимы для того, чтобы данный интерфейс начал определение типа инкапсуляции кадров, передаваемых по транковому соединению.

 

SW1#configure

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line. End with CNTL/Z.

SW1(config)#interface fastEthernet 0/2

SW1(config-if)#switchport mode access

SW1(config-if)#switchport access vlan 3

SW1(config-if)#^Z

 

SW1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

SW1(config)#interface fastEthernet 0/1

SW1(config-if)#switchport mode dynamic desirable

SW1(config-if)#switchport mode trunk

SW1(config-if)#^Z


Коммутатор SW2 будем настраивать как VTP клиент. Для этого в режиме конфигурации VLAN создаём VTP домен vtp_test и вводим команду "VTP client". После этого в режиме глобальной конфигурации помещаем порт fa0/2 в VLAN 3, а fa0/1 переводим в режим switchport dynamic auto. Если порты на двух концах транкового соединения установить в режим dynamic auto, то транкового соединения между коммутаторами не сформируется, так как оба порта будут находиться в режиме ожидания.

SW2#vlan database

SW2(vlan)#vtp domain vtp_test

SW2(vlan)#vtp client

Setting device to VTP CLIENT mode.

SW2#configure

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line. End with CNTL/Z.

SW2(config)#interface fastEthernet 0/2

SW2(config-if)#switchport mode access

SW2(config-if)#switchport access vlan 3

SW2(config-if)#^Z

SW2#configure

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line. End with CNTL/Z.

SW2(config)#interface fastEthernet 0/1

SW2(config-if)#switchport mode dynamic auto

SW2(config-if)#^Z

 

В принципе можно просто включить транковые соединения непосредственно на коммутаторе, так как заранее известно, какие порты будут транковыми. Но режим auto и desirable позволяют конфигурировать транковые соединения удаленно.

Для просмотра состояния транкового соединения можно использовать команды "show interfaces fastEthernet 0/1 switchport" или "show interfaces fastEthernet 0/1 trunk".

 

SW1#show interfaces fastEthernet 0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: dynamic auto

Operational Mode: static access

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: native

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Для просмотра состояния VTP можно воспользоваться командой “show vtp status”

SW2#show vtp status

VTP Version : 2

Configuration Revision : 7

Maximum VLANs supported locally : 64

Number of existing VLANs : 5

VTP Operating Mode : Client

VTP Domain Name : vtp_test

VTP Pruning Mode : Enabled

VTP V2 Mode : Enabled

VTP Traps Generation : Disabled

MD5 digest : 0x28 0x29 0x38 0xCB 0xAB 0xB6 0x1F 0xD5

Configuration last modified by 172.10.2.10 at 3-3-93 22:13:38

SW2#


 

Настройка транкового соединения ISL.

ISL работает на соединениях типа точка- точка и передает трафик от множества VLAN по одному соединению. Рассмотрим последовательность настройки транкового ISL на коммутаторе Сatalyst серии 4000.

Для установки типа инкапсуляции ISL необходимо войти в подрежим настройки интерфейса и выполнить команду switchport trunk encapsulation. Затем, используя команду switchport mode trunk, настраивается интерфейс для работы в качестве транка 2 уровня.

 

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#interface gigabitEthernet 2/24

Switch(config-if)#shutdown

Switch(config-if)#switchport trunk encapsulation isl

Switch(config-if)# switchport mode trunk

Switch(config-if)#no shutdown

Switch(config-if)#^Z

 




©2015 studopedya.ru Все права принадлежат авторам размещенных материалов.