Помощничек
Главная | Обратная связь


Археология
Архитектура
Астрономия
Аудит
Биология
Ботаника
Бухгалтерский учёт
Войное дело
Генетика
География
Геология
Дизайн
Искусство
История
Кино
Кулинария
Культура
Литература
Математика
Медицина
Металлургия
Мифология
Музыка
Психология
Религия
Спорт
Строительство
Техника
Транспорт
Туризм
Усадьба
Физика
Фотография
Химия
Экология
Электричество
Электроника
Энергетика

Настройка наложения внутренних глобальных адресов (PAT).



 

Для настройки РАТ устанавливается стандартный список контроля доступа (АСL) (номер от 0 до 99), который будет разрешать транслировать внутренние локальные адреса. Для группы последовательных адресов можно применить wildcard mask. Если адреса являются непоследовательными, то каждый адрес описывается отдельной строчкой в ACL.

 

Router (config)# access-list access-list—number permit source [source-wildcard]

 

Затем необходимо установить динамическую трансляцию адресов источника в соответствии с сформированным ACL. Ключевое слово “overload’ включает РАТ.

 

Router (config) # iр nat inside source list access-list-numberinterfaceinterface overload

 

Определяем, какой интерфейс маршрутизатора будет являться внешним локальным. Входим в подрежим конфигурирования этого интерфейса и вводим команду ip nat inside.

 

Router(config)# interfacetype number

Router(config-if)# ip nat inside

 

Определяем, какой интерфейс маршрутизатора будет являться внешним. Входим в подрежим конфигурирования этого интерфейса и вводим команду ip nat outside.

 

Router(config)# interfacetype number

Router(config-if)# ip nat outside

 

Для удаления пула глобальных адресов необходимо в режиме глобальной конфигурации надо ввести команду no ip nat pool.

Для удаления ACL необходимо в режиме глобальной конфигурации надо ввести команду no ассеss-list ассеss-list- number.

Для отключения динамической трансляции адресов источника в режиме глобальной конфигурации надо ввести команду no iр nat inside source.

 

Настроим PAT.

 

R1(config)#interface fastethernet 0/0

R1(config-if)#ip address 10.1.1.1 255.255.255.0

R1(config-if)#ip nat inside

R1(config-if)#^Z

R1(config)#interface serial 0/0

R1(config-if)#ip address 200.1.1.1 255.255.255.0

R1(config-if)#ip nat outside

R1(config-if)#^Z

R1(config)#access-list 1 permit 10.1.1.2 0.0.0.255

R1(config)#access-list 1 permit 10.1.1.3 0.0.0.255

R1(config)#access-list 1 permit 10.1.1.4 0.0.0.255

R1(config)#^Z

R1(config)#ip nat inside source list 1 interface serial 0/0 overload

Просмотр результатов настройки можно выполнить с помощью команды show running-config.

 

R1#show running-config

!

interface Serial0

ip address 200.1.1.1 255.255.255.0

no ip directed-broadcast

clock rate 56000

bandwidth 1544

ip nat outside

!

interface Serial1

no ip address

no ip directed-broadcast

bandwidth 1544

!

interface FastEthernet0/0

ip address 10.1.1.1 255.255.255.0

no ip directed-broadcast

bandwidth 100000

ip nat inside

!

router eigrp 1

network 10.0.0.0

network 200.1.1.0

!

ip nat inside source list 1 interface Serial0 overload

ip classless

no ip http server

ip route 0.0.0.0 255.255.255.255 200.1.1.1

access-list 1 permit 10.1.1.2 0.0.0.255

access-list 1 permit 10.1.1.3 0.0.0.255

access-list 1 permit 10.1.1.4 0.0.0.255

!

line con 0

transport input none

line aux 0

line vty 0 4

!

no scheduler allocate

end

Для просмотра информации о трансляции надо выполнить команду show ip nat translations, которая показывает активные трансляции.

R1#show ip nat translations

Pro Inside global Inside local Outside local Outside global

icmp200.1.1.1:9392 10.1.1.2:9392 200.1.1.2:9392 200.1.1.2:9392

icmp200.1.1.1:9393 10.1.1.2:9393 200.1.1.2:9393 200.1.1.2:9393

icmp200.1.1.1:9394 10.1.1.2:9394 200.1.1.2:9394 200.1.1.2:9394

icmp200.1.1.1:9395 10.1.1.2:9395 200.1.1.2:9395 200.1.1.2:9395

icmp200.1.1.1:9396 10.1.1.2:9396 200.1.1.2:9396 200.1.1.2:9396

 

Для просмотра статистики по трансляциям надо выполнить команду show ip nat statistics.

R1#show ip nat statistics

Total active translations: 0 (0 static, 0 dynamic; 0 extended)

Outside interfaces:

Serial0/0

Inside interfaces:

FastEthernet0/0

Hits: 0 Misses: 0

Expired translations: 0

Dynamic mappings:

-- Inside Source

access-list 1 interface Serial0/0 refcount 0

R1#





©2015 studopedya.ru Все права принадлежат авторам размещенных материалов.